Update travis build to openjdk11

Description

None

Activity

Show:
All Replies
April 17, 2019, 9:21 PM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was buildandpackaging] Ross Gale mentioned this issue in a merge request of records-management/records-management:
'RM-6825 update travis to use openjdk11'

Rodica Sutu
April 18, 2019, 7:07 PM
Edited

Travis build is failing as the OpenJDK version used is 11.0.2 and not 11.0.1 the one used in Bamboo
The RM project fails to build on Open JDK 11.0.2 when generating the java docs.
Questions:
Should RM be built with Open JDK 11.0.2? Yes
How should we fix the java docs set to not fail on warning errors on java docs or fix the java docs to not have those?
Configure the maven java doc plugin to not fail the build when having errors on javadoc generation but open a task to fix this going forward

All Replies
April 22, 2019, 6:12 PM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was buildandpackaging] Rodica Sutu mentioned this issue in a merge request of records-management/records-management:
'Increase Travis timeout'

All Replies
October 31, 2020, 10:06 AM

[This issue has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The reporter of this issue was rgale]

Done

Assignee

Unassigned

Reporter

All Replies

Labels

None

Release Train

None

Delivery Team

None

Time remaining

0m

Sprint

None

Priority