Outlook Integration shows wrong "sent on" timestamp in Alfresco pane

Description

If ACS and client are in different timezone, emails dragged from Outlook to the Alfresco pane show the wrong "sent on" timestamp in the Alfresco pane. The timestamp is reflecting the difference in timezones when it shouldn't, e.g. if ACS is in GMT-6 and the client in GMT-8, the timestamp in the Alfresco pane will apply the 2 hour difference and display the timestamp as GMT-10 (see screenshot).

Steps to Reproduce
1. Set your Windows client to a different timezone from ACS.
2. Drag an email from Outlook into the Alfresco pane.
3. Compare the timestamp from Outlook to the timestamp in the Alfresco pane.

Expected Behavior
The timestamps should be the same.

Actual Behavior
The timestamp in the Alfresco pane shows the wrong timestamp, reflecting the differences in timezones of the server and client.

Notes
The "sent date" timestamp is also displayed in Share document details page, and also shows the wrong timestamp.

Environment

ACS 6.2.2, OI 2.7.1

Testcase ID

None

Activity

Show:
Scott Ashcraft
January 22, 2021, 12:49 AM

Customer is using OI 2.4.10.2 and experiences the same behavior.

Assignee

Unassigned

Reporter

Scott Ashcraft

Labels

None

ACT Numbers

01022197

Security Issue

None

Patch Attached

None

Premier Customer

None

Prioritization Score

None

Delivery Team

None

Build Location

None

Cloud or Enterprise

None

Bug Priority

Category 3

Work Funnel End

None

Escalated By

None

Dependent Version/s

None

Regression Since

None

Code Branch

None

Components

Fix versions