File is not displayed in case deploy is made by different users via avm deployment receiver on Test server

Description

1. Alfresco is installed at least on 2 nodes;
2. DM Deployment server is started on 2 nodes (to enable DM Deployment add the following string to alfresco-global properties):
deployment.dmr.consolidate=TRUE
deployment.dmr.name=alfresсo
3. Any Web Project with workflow is created;
4. DR server is configured ( Type: Test Server, Host: other_server, Port: 50500, Target Name:
alfresco, Name; Test1);
5. DR server is configured ( Type: Test Server, Host: other_server, Port: 50500, Target Name:
alfresco, Name; Test2);
6. User with Content Manager role for created Web Project is logged in to Alfresco;
7. Any content File1 is added in Content Manager's Sandbox;
8. Click "Deploy" link in "More Actions" menu (User Sandbox);
9. Choose Test1 and click "Ok" - Location "Web Deployed" contain "web_project_name"/ROOT/"File1"

10. Any content File2 is added in Content Reviewer's Sandbox;
11. User with Content Reviewer role for created Web Project is logged in to Alfresco;
12. Click "Deploy" link in "More Actions" menu (User Sandbox);
13. Choose Test1 and click "Ok"

Actual result:
Location "Web Deployed" contain "web_project-name"/ROOT/"File2"

Expected result:
Location "Web Deployed" contain "web_project-name"/ROOT/File1 and File2

AndreyMa

Environment

Alfresco 3.2r 415 Windows 2008 SP1 x64, Tomcat 6.0.18, Mysql 5.1.39, JDK 6u16 x64

Testcase ID

WCM-868 and WCM-869

Activity

Show:
All Replies
October 31, 2020, 1:14 AM

[This issue has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The reporter of this issue was alfrescoqa]

Derek Hulley
August 31, 2016, 12:32 PM

The component originally used was not a supported, recognisable system component with an associated component owner. Either the component never existed (it was fictional) or it has reached end-of-life.
The issues will be closed. Reopen and assign to an existing system component if necessary. Use labels appropriately.

All Replies
May 13, 2010, 1:12 PM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was alfrescoqa] Closed as "Not a bug"

All Replies
May 12, 2010, 10:39 AM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was srigby] For retest in 3.3E build 27

All Replies
April 27, 2010, 10:28 AM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was mrogers] The test is not correct.

Not a bug

Assignee

All Replies

Reporter

All Replies