User quota reporting negative use!

Description

During deletion of content in users home space, WARN messages are output to console like:

16:00:18,732 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-146793400) overriding to 0
16:00:18,756 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-147926968) overriding to 0
16:00:18,784 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-148046776) overriding to 0
16:00:18,814 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-149180344) overriding to 0
16:00:18,835 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-149300152) overriding to 0
16:00:18,857 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-150433720) overriding to 0
16:00:18,879 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-150553528) overriding to 0
16:00:18,900 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-151687096) overriding to 0
16:00:18,931 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-152820664) overriding to 0
16:00:18,955 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-152864184) overriding to 0
16:00:18,982 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-152907704) overriding to 0
16:00:19,006 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-152951224) overriding to 0
16:00:19,036 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-152994744) overriding to 0
16:00:19,063 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-153038264) overriding to 0
16:00:19,093 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-153081784) overriding to 0
16:00:19,132 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-153125304) overriding to 0
16:00:19,185 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-153168824) overriding to 0
16:00:19,214 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-153212344) overriding to 0
16:00:19,247 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-153255864) overriding to 0
16:00:19,275 WARN [org.alfresco.repo.usage.ContentUsageImpl] User usage (test) is negative (-153256154) overriding to 0

Surely this is incorrect?

Note, the route the content got into the system was:
UserA upload X documents to SpaceA in their home space.
Rule runs on content uploaded to SpaceA, copying it to SpaceB 10 times (renaming it to copy0 - copy9).
Rule runs on SpaceB, transforming content and putting it into SpaceC.
These User Usage messages were shown when deleting content from SpaceC and SpaceB.

Environment

3.2r b398, RHEL, MySQL.

Testcase ID

None

Activity

Show:
All Replies
October 31, 2020, 1:14 AM

[This issue has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The reporter of this issue was srigby]

All Replies
October 21, 2010, 7:28 AM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was rivarola] Still the problem in 3.4 Enterprise beta 1 :
18:45:48,697 User:admin WARN [repo.usage.ContentUsageImpl] User usage (workspace://SpacesStore/e78ef21b-c5eb-484a-9daf-52f2dcb72905) is negative (-209777) overriding to 0

It seems it appeared after I imported an ACP and then deleted all the imported spaces tree.

All Replies
April 16, 2010, 3:13 PM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was alfrescoqa] Cannot reproduce on Alfresco 3.3G b 2785
RHEL 5.1 x64, Tomcat 6.0.18, Mysql 5.1.35, JDK 6u16 x64

All Replies
April 16, 2010, 9:28 AM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was srigby] For retest in 3.3 b2785

All Replies
April 15, 2010, 12:42 PM

[This comment has been reassigned to allreplies@alfresco.com as part of the Alfresco cloud migration project. The author of this comment was sglover] I can't reproduce this on HEAD. Some fixes have been applied in 3.2E (see linked forum article) w.r.t. node creation/deletion policy firing that may have fixed this issue. However, I did spot a potential race condition in the user usage tracking component that may cause this in extreme circumstances. I have fixed this.

Fixed

Assignee

All Replies

Reporter

All Replies